Intro

EchoLinkPlus 2.1

von DK6XH & DC4FS

Zusatzprogramm zu EchoLink.exe von K1RFD

für die Besonderheiten und Erfordernisse bei der Anbindung von

EchoLink an automatisch betriebene Stationen (Repeater oder Links)


Kurzbeschreibung

EchoLinkPlus 2.1

Version: | 2.1.0
Version EchoLink und EchoLinkPlusConfig: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlusConfig.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Kurzbeschreibung

EchoLinkPlus ist ein Zusatzprogramm zu EchoLink.exe von K1RFD, welches speziell für die Besonderheiten und Erfordernisse bei der Anbindung von EchoLink an automatisch betriebene Stationen (Repeater oder Links) entwickelt wurde.

Die Kommunikation zwischen EchoLink.exe und EchoLinkPlus.vbs erfolgt über die Programmierschnittstelle zum implementierten COM Automationsserver.

EchoLinkPlus besteht aus zwei Modulen:

EchoLinkPlusConfig.vbs - menügeführte Konfiguration - dient der Konfiguration von EchoLinkPlus.vbs.

und

EchoLinkPlus.vbs - ausführendes Programm

Zweck von EchoLinkPlus 2.1

Die seit Mitte 2003 gesammelten Erfahrungen mit dem Betrieb eines EchoLink-Gates am Augsburger 2m-Relais DB0UA haben gezeigt, dass der EchoLink-Betrieb über Relais nicht unproblematisch ist. Da ist zunächst einmal der unvermeidbare »Spieltrieb« einiger Zeitgenossen, der mitunter einen vernünftigen Betrieb erschwert bis völlig unmöglich macht. Auch wissen offenbar viele (noch) nicht, dass EchoLink längere Umschaltpausen benötigt.

Gravierende »Mängel« offenbaren sich beim EchoLink-Betrieb über Relais, weil die Software dafür eigentlich nicht geschrieben wurde.

Einige Beispiele:

  • Jemand connected ein Relais auf dem gerade lokaler Betrieb läuft und die Benutzer lassen viel zu kurze Umschaltpausen. Die Folge ist, dass man solche Verbindungen kaum trennen kann und es dauert mitunter recht lange, bis sie ein Ende finden.
    Wohl deshalb haben etliche SysOps von EchoLink-Repeatern den Zugang anderer Relais auf ihr System gesperrt. Nicht besonders sinnvoll, denn gerade solche Verbindungen sind für FUNKamateure interessant, um EchoLink nicht gänzlich zur reinen PC to PC Kommunikation verkümmern zu lassen.

    • Eine Verbindung zu EchoLink wird bei der Mikrofonübergabe durch einen »freundlichen« Zeitgenossen mittels DTMF-Taste # getrennt. Wenn der Gesprächspartner am anderen Ende an seinem PC sitzt, bemerkt er dies sofort, aber wenn die Verbindung von Relais zu Relais geht, bekommt man oft gar nicht mit, dass die Verbindung längst nicht mehr besteht.

    • Hinzu kommt die Tatsache, dass »die ganze Welt« mithören kann und so die bislang gewohnte (jedoch nur vermeintliche) »Vertrautheit« der Gespräche nicht mehr gegeben scheint. Dann ist da noch die Sorge etlicher User, auf einem solchen Relais womöglich von einem »Ami« angesprochen zu werden - nachdem das eigene Englisch etwas holprig ist, befürchtet man, sich zu blamieren und meidet dieses Relais ganz.

    • Ein weiterer Umstand ist der »Krawall«, den EchoLink mit sich bringt.
      »1 - 3 - 4 - 5 - 9 - 2 - not found« oder
      »Connecting to D - B - 0 - U - A - Repeater« -
      auf Dauer kann das die Zuhörer schon ganz schön nerven.
      Insbesondere wenn manche Gegner von EchoLink Gateways auf Repaetern (und davon gibt es etliche) mal wieder stundenlang (anonym) demonstrieren, was sie schon seit langer Zeit predigen: »Bitteschön, da hört ihr's - EchoLink gehört verboten!«.

  • »EchoLink über ein Relais ist ganz großer Käse ...« - das ist mittlerweile das Fazit, das nicht wenige User und auch etliche Relaisbetreiber ziehen.

Die beklagten Umstände lassen sich aber durchaus verbessern. Das Script-Programm EchoLinkPlus wurde speziell für den Relais- bzw. Link-Betrieb von EchoLink geschrieben und »entschärft« einige der beklagten »Missstände«.

Eigenschaften EchoLinkPlus 2.1

  • EchoLinkPlus ist nur ein Script zum Start und Überwachung von EchoLink

  • Eigenes interaktives Konfigurationsscript, Änderungen werden von EchoLinkPlus direkt übernommen

  • Prüfung, ob die eigene Station im Verzeichnis steht, ansonsten Reset

  • Wahlweise Abschaltung der Ansagen »1 4 4 2 3 NOT FOUND« oder "CONNECTING TO D - B - 0 - U - A - Repeater", etc.

  • Ausgabe deutscher Ansagetexte, z.B. "verbunden mit Delta Bravo Null Uniform Alpha Repeater" wenn sich die verbundene Station nicht selbst vorstellt

  • Selbst gestaltete Ansagetexte in allen Sprachen sind möglich, einfach die Wav-Dateien ersetzen.

  • Ausgabe nur noch kurzer Bestätigungen in CW für [N]icht erreichbar, [B]esetzt, [A]bgewiesen

  • Vergabe von beliebigen dreistelligen Kurzwahlnummern möglich

  • Automatische Trennung von unbeabsichtigten EchoLink-Verbindungen, welche den Relaisbetrieb blockieren nach einer bestimmten Zeit (z. B. Connects zu Repeatern, die keine Umschaltpause lassen)

  • Eine connectete Station wird nicht auf dem Repeater angesagt, solange der Repeater nicht aufgetastet ist und die connectete Station sich nicht meldet. Erst ein Phoniesignal öffnet den Repeater und die Station wird über die Ausgabe ausgestrahlt. "Blinde" Connects werden nicht mehr angesagt.

  • Wird eine Station vom Repeater aus connectet, so wird die Station nur angesagt, wenn sie selbst keine Information (Welcome-Text) ausstrahlt.

  • Gewährung eines Vorrangs für lokalen Funkbetrieb möglich

  • kurzzeitige Abschaltung des lokalen Vorrangs per DTMF möglich

  • Aus- und wieder einschalten des Inaktivitätstimers per DTMF möglich

  • Möglichkeit der Abschaltung von EchoLink zu Nachtzeiten

  • Wahlweise spezielle Abschaltung an einem bestimmten Wochentag (z. B. für Rundsprüche)

  • Mögliche Sperrung der Informationsabfragen zu bestimmten Zeiten

  • Anzeige des Status »Local Busy«, »Connected« und »free« in der EchoLink-Stationsliste (s.u.)

  • Spezieller Sysopmodus zur Aktivierung oder Deaktivierung einiger Funktionen

  • Ausgabe von Hilfetexten (*0 - *9) oder aktuellen Informationen

  • Schaltbare Zeitansage mit Zeitzeichen

  • Ausgabe einer Fehlermeldung bei Fehleingabe.

  • Eingaben werden nun quittiert. Anfangs noch mit Infotext, später nur noch durch CW-Zeichen.

  • Abschaltung von EchoLink für eine bestimmte Zeit bei Fehlbedienung oder Fehlfunktion

  • Disconnect erst nach Überprüfung zur Vermeidung von ungewollten Trennungen. Die Disconnect-Routine wurde noch weiter verbessert.

  • Reconnect (09) nur für eine bestimmte Zeit möglich

  • Ansage der zuletzt connecteten Station bei Statusabfrage (08) so lange die Möglichkeit zum Reconnect besteht

  • Ausgabe der eigenen Nodenummer (*#)

  • Der Start der stündlichen/halbstündlichen Ausgabe wird nun über die Dateilänge selbst bestimmt, so dass pünktlich zur vollen/halben Stunde das Zeitzeichen ausgegeben wird. Generell wird nun die Länge eines jeden WAV-Files bestimmt und der Programmfortschritt daran angepasst.

Kurzbeschreibung - Programmausführung

EchoLinkPlusConfig.vbs

Konfiguration - dient der Konfiguration von EchoLinkPlus.vbs.

Vor dem Start von EchoLinkPlus.vbs muss das Konfigurierungsprogramm EchoLinkPlusConfig.vbs mindestens ein Mal aufgerufen worden sein.

Dies ist erforderlich, weil EchoLinkPlusConfig.vbs die darin festgelegten Parameter und Werte in die Windows-Registry schreibt.

Nach Start des ausführenden Programms EchoLinkPlus.vbs werden diese Parameter und Werte aus der Registry gelesen und stehen damit für die Programmausführung zur Verfügung.

Dieses Script kann jederzeit aufgerufen werden, auch zur Laufzeit des Programms EchoLink.exe und EchoLinkPlus.vbs.

EchoLink muss deswegen nicht beendet werden.

Jeder Aufruf von EchoLinkPlusConfig.vbs überschreibt die EchoLinkPlus-spezifischen Daten in der Windows-Registry und weist dem Schlüssel [HKCU\Software\K1RFD\EchoLink\Options\LocationFree], den String »Waiting for update« zu. Dieser Eintrag wird u. U. auch in der EchoLink-Stationsliste angezeigt.

Bei der nächsten Erneuerung (Refresh) der Stationsliste werden bei Vorhandensein der vorstehend beschriebenen »Markierung« die Daten neu aus der Registry eingelesen.

Dieser Vorgang kann auch manuell ausgelöst werden, durch Klicken auf den Button »Refresh station list« in der EchoLink-Toolbar.

EchoLinkPlus.vbs

ausführendes Programm - läuft mit den in der Windows-Software enthaltenen Programmen WScript.exe oder wahlweise mit CSript.exe .

EchoLinkPlus.vbs ruft nach dem Start automatisch das Programm EchoLink.exe auf.

Hinweis:

Vor dem Start von EchoLinkPlus.vbs muss das Konfigurierungsprogramm EchoLinkPlusConfig.vbs mindestens ein Mal aufgerufen worden sein.

Dies ist erforderlich, weil EchoLinkPlusConfig.vbs die darin festgelegten Parameter und Werte in die Windows-Registry schreibt.

Nach Start des ausführenden Programms EchoLinkPlus.vbs werden diese Parameter und Werte aus der Registry gelesen und stehen damit für die Programmausführung zur Verfügung.

History

Der Anwendung EchoLinkPlus liegen folgende frühere Entwicklungen zugrunde, die vollständig oder in Teilen mit Änderungen integriert wurden:

  • getDTMF.vbs von Thomas Beiderwieden, DL3EL, erweitert von Rüdiger Stenzel, DC4FS

  • CheckLOGIN.vbs von Hermann Böhm, DK6XH

  • Stunde.vbs von Hermann Böhm, DK6XH

Haftungsausschluss

Jegliche Haftung für enthaltene Fehler sowie Fehler in den Anwendungen EchoLinkPlus.vbs und EchoLinkPlusConfig.vbs ist ausgeschlossen.

Die Verwendung erfolgt ausschließlich auf eigenes Risiko und eigene Gefahr.

Wer diese Anwendungen benutzt, erkennt diesen Haftungsausschluss ab der ersten Nutzung an.

Zu dieser Dokumentation

Diese Dokumentation wurde erstellt von DK6XH & DC4FS.

Stand: 02 - 19.03.2004


EchoLinkPlus Befehle

EchoLinkPlus 2.1

Beschreibung der DTMF-Befehle zur Steuerung
DTMF | Beschreibung
nnnnnn | Verbindungsaufbau zu Station nnnnnn mit deutscher Ansage (1)
Annnnnn | Verbindungsaufbau zu Station nnnnnn mit englischer Ansage (2)
neu Dnn | Kurzwahl (auch #nn, nnn oder Bnn als Alternativen) (3)
# | Trennt die zuletzt verbundene Station nach Überprüfung (4)
## | Trennt alle Stationen nach Überprüfung (4)
08 | Statusabfrage mit Ausgabe der zuletzt verbundenen Station (5)
09 | Verbindungsaufbau zu der zuletzt verbundenen Station (6)
* | Stationsinformation
*0 ... *9 | Informationstexte
** | Ansage der lokalen Zeit
*# | Ansage der Node-Nummer
neu 04 | Schaltet bei lokalem QSO EchoLink wieder zu (7)
neu 05 | Schaltet den Inaktivitäts-Timer aus und wieder an (8)
Sysop-Befehle nach Eingabe des Sysop-Passworts
0#00 | Echolink ausschalten
0#01 | Echolink einschalten
0#10 | Timer ausschalten (RX-, TX- und Inaktivitäts-Timer)
0#11 | Timer einschalten
0#20 | Ansagen ausschalten
0#21 | Ansagen einschalten
0#22 | Aktuelle Mitteilungen ausschalten
0#23 | Aktuelle Mitteilungen einschalten
0#30 | Nachtabschaltung ausschalten
0#31 | Nachtabschaltung einschalten
0#40 | Temporäre Abschaltung (Rundsprüche, etc.) ausschalten
0#41 | Temporäre Abschaltung einschalten
0#50 | Lokalen Vorrang ausschalten
0#51 | Lokalen Vorrang einschalten
0#99 | Script beenden
0### | Script sofort beenden
0#** | Aktuelle Einstellungen ansagen
0##0 | Konfiguration neu laden

Anmerkungen:
(1) Es erfolgen keine Ansagen wie "connecting to [call]" oder "nnnnnn not found". Eine hergestellte Verbindung wird durch ein "K" ( _._ ) angezeigt. Es meldet sich die Gegenstation mit der Stationsinformation oder die Verbindung wird von EchoLink+ angesagt.
Ist kein Connect möglich, so wird der Grund kurz angesagt:
Ist die Station nicht verfügbar, so wird "_. nicht erreichbar" (not found) ausgegeben,
ist sie besetzt, so wird "_... besetzt" (busy) angesagt.
Eine Abweisung wird mit "._ abgewiesen" (access denied) und
Fehleingaben werden mit " ........ Fehler" (8x error) quittiert.
Ist der Grund drei mal in Phonie angesagt worden, so wird nur noch das CW-Zeichen ausgegeben.

Hinweis: Der Verbindungsaufbau, bzw. die Ansage für eine Abweisung kann bis zu 15s dauern!
(2) | Wird ein "A" der Node-Nummer vorangestellt, so wird der Connect-Text weiterhin wie gewohnt in Englisch angesagt. Die anderen Prozeduren gelten wie unter (1)
(3) Ab der Version 2.1 ist eine frei konfigurierbare Kurzwahl möglich.
Einzige Bedingung: Die Kurzwahlnummern müssen dreistellig sein und können beliebige DTMF-Zeichen beinhalten, außer den von EchoLink bzw. anderweitig reservierten Zeichenfolgen.
Vorschlag: Eine Kurzwahl ist in mehreren Systemen möglich. Die wichtigsten Repeater und Linkstationen können mit drei DTMF-Zeichen verbunden werden.

Dnn oder #nn verbindet nach Rufzeichen. Maßgeblich sind die beiden ersten Buchstaben des Suffix.
nnn verbindet ebenfalls nach Rufzeichen. Maßgeblich sind die drei letzten Stellen des Calls.
Bnn verbindet nach Bereich (PLZ). Maßgeblich sind die beiden ersten Ziffern des PLZ-Bereichs.

(4) Die Trennung erfolgt nur nach einer Prüfung (wenn aktiviert). Sollte ein Trennungszeichen (#) während eines Gesprächs eingegeben werden, so wird es ignoriert, wenn weiter gesprochen wird. Zur Trennung (#) oder (##) ist also eine Pause nach der Eingabe erforderlich.
Eine Trennung erfolgt auch automatisch nach 30s Inaktivität.
Die Trennung wird durch 5 Punkte ( ..... ) signalisiert.
(5) | Die Statusabfrage "08" gibt den Zustand des Repeaters/Links an. Ist eine Station verbunden, so wird dies angesagt. Ebenso, wenn keine Verbindung besteht. In diesem Fall wird noch die zuletzt verbundene Station ausgegeben, wenn diese vor weniger als die eingestellte Zeit mit dem Repeater/Link verbunden war. Dann kann eine erneute Verbindung mit "09" hergestellt werden.
(6) | Der Reconnect "09" verbindet mit der zuletzt verbundenen Station nur dann, wenn diese vor weniger als die in der Konfiguration eingestellte Zeit mit dem Repeater/Link verbunden war.
(7) Findet ein lokales QSO auf dem Repeater statt, so wird der EchoLink-Zugang automatisch deaktiviert.
Mit Dem Befehl "04" (frei wählbar) kann EchoLink wieder zugeschaltet werden, wenn dies explizit gewünscht wird, z.B. bei Verabredungen über EchoLink auf dem Repeater. Dieser Befehl kann nur von der HF-Seite ausgeführt werden.
(8) Wird eine EchoLink-Verbindung aufgebaut, so wird automatisch nach Ablauf des Inaktivitäts-Timers die Verbindung wieder getrennt, wenn keine Aktivität auf beiden Seiten festgestellt wird.
Dies ist in der Regel sinnvoll.
Mit dem Befehl "05" (frei wählbar) kann diese automatische Trennung deaktiviert und wieder aktiviert werden. Es erfolgt jeweils eine Ansage. Dieser Befehl kann nur von der HF-Seite ausgeführt werden.
Nach dem nächsten Disconnect wird der Inaktivitäts-Timer automatisch wieder aktiviert.

Spezielle Funktionen von EchoLinkPlus:

Findet ein lokales Gespräch statt, so schaltet der Repeater/Link EchoLink ab. Nach Außen wird der Repeater/Link als "besetzt" gemeldet. Nach dem Gespräch und einer Pause von 30-60s wird dann EchoLink wieder eingeschaltet, eine Verbindung über EchoLink ist dann wieder möglich.

Wird nach einem Verbindungsversuch ein belegter Repeater vorgefunden, bei dem keine Sprechpausen bestehen und somit auch keine Trennung (#) möglich wäre, so wird nach 60s automatisch die Verbindung wieder getrennt. Bei einem erneuten Versuch und erneuter Belegung des Repeaters, wird bereits nach 30s automatisch getrennt und der Echolinkzugang zur Sicherheit kurzfristig deaktiviert.

Verbindet sich eine Station über EchoLink mit den Repeater/Link, so wird diese Verbindung erst auf den Repeater/Link geschaltet, wenn sich diese Station in Phonie meldet. Somit werden "blinde" Connects nicht zur Ausgabe durchgeschaltet, die Frequenz bleibt ruhig.

Zu dieser Dokumentation

Diese Dokumentation wurde erstellt von DK6XH & DC4FS.

Stand: 02 - 19.03.2004


EchoLinkPlus 2.1

Version: | 2.1.0
Version EchoLink und EchoLinkPlusConfig: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlusConfig.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

EchoLinkPlus ausführen

Starten von EchoLinkPlus.vbs

Der Start von EchoLink mit EchoLinkPlus kann auf zwei Arten geschehen:

  • Das Programm EchoLink.exe starten;
    EchoLinkPlus.vbs     starten

  • Nur EchoLinkPlus.vbs starten
    EchoLink.exe     wird automatisch gestartet.
    Diese Methode wird empfohlen, weil einfacher.

Hierzu rufen Sie das im Verzeichnis »...\Programme\K1RFD\EchoLink\EchoLinkPlus« enthaltene Script EchoLinkPlus.vbs auf.

Wenn Sie hierzu auf Ihrem Desktop einen Link erstellt haben, einfach auf das Icon klicken.

Siehe hierzu auch WScript.exe oder CScript.exe?

Hinweis:

Vor dem Start von EchoLinkPlus.vbs muss das Konfigurierungsprogramm EchoLinkPlusConfig.vbs mindestens ein Mal aufgerufen worden sein.

Dies ist erforderlich, weil EchoLinkPlusConfig.vbs die darin festgelegten Parameter und Werte in die Windows-Registry schreibt.

Nach Start des ausführenden Programms EchoLinkPlus.vbs werden diese Parameter und Werte aus der Registry gelesen und stehen damit für die Programmausführung zur Verfügung.

Das Konfigurations-Script EchoLinkConfig.vbs kann jederzeit aufgerufen werden, auch zur Laufzeit des Programms EchoLink.exe und EchoLinkPlus.vbs. Das Programm EchoLink muss deswegen nicht beendet werden.

Die Aktualisierung der Werte aus der EchoLinkConfig.vbs erfolgt regelmäßig mit der Aktualisierung der EchoLink-Statonsliste (NodeList), so dass nach der Änderung und dem Aufruf der EchoLinkConfig.vbs keine weiteren Aktionen folgen müssen.

  • Zum einfacheren Aufrufen von EchoLinkPlus, des Konfigurationsscripts und der Kurzwahlliste sind bei EchoLinkPlus 2.1 Links beigefügt, die auf den Desktop kopiert werden können und sofort funktionieren, wenn EchoLink.exe im Standartpfad liegt. Sonst müssen sie noch mit "Eigenschaften" auf den richtigen Pfad angepasst werden.

EchoLinkPlus beenden

  • Wenn die Anwendung EchoLinkPlus.vbs unter Verknüpfung mit WScript.exe gestartet wurde, kann diese normalerweise nur beendet werden, indem das Programm EchoLink.exe beendet wird. Diese Methode wird jedoch nicht empfohlen.

Hinweis:

Bei dieser Methode kann es vorkommen, dass EchoLink.exe und/oder WScript.exe nicht richtig beendet werden und Reste der Anwendungen im System bleiben.

Vor einem Restart von EchoLinkPlus.vbs sollte in solchen Fällen mit Hilfe des Task Manager eine Überprüfung durchgeführt und ggf. verbliebene Teile entfernt werden. Dies kommt vor, da EchoLink.exe weiterhin versucht auf den Automatenserver zuzugreifen, obwohl der keine Daten mehr erhält.

Das Neustarten von EchoLinkPlus.vbs nach Änderung der Konfiguration ist jedoch nicht nötig, da die Änderungen beim nächsten Refrech von EchoLinkPlus.vbs automatisch übernommen werden.

Siehe hierzu auch WScript.exe oder CScript.exe?

Es wird ausdrücklich empfohlen, EchoLinkPlus nicht mit <Strg> C zu beenden, falls die Anwendung mit CScript gestartet wurde.

  • Dem Paket EchoLinkPlus 2.1 ist ein Script »ShutDownEchoLinkPlus.vbs« beigefügt, das verhindern soll, dass Teile von EchoLink.exe im Task erhalten bleiben.

Hierzu rufen Sie das im Verzeichnis »...\Programme\K1RFD\EchoLink\EchoLinkPlus« enthaltene Script ShutDownEchoLinkPlus.vbs auf.

Wenn Sie hierzu auf Ihrem Desktop einen Link erstellt haben, einfach auf das Icon klicken.

Bestätigen Sie mit [Ja].

Danach lässt sich EchoLink.exe normal schließen; es bleiben keine Fragmente zurück.

Sie sollten also immer zuerst das Script EchoLinkPlus.vbs beenden und erst danach das Programm EchoLink.exe.


WScript.exe oder CScript.exe?

EchoLinkPlus 2.1

Version: | 2.1.0
Version EchoLink und EchoLinkPlusConfig: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlusConfig.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

WScript.exe oder CScript.exe ?

Was unterscheidet wscript.exe und csript.exe?

WSH umfasst zwei eng verwandte Scripting Hosts: WScript und CScript. Beide sind hinsichtlich ihres Befehlsumfangs nahezu gleich. Sie unterscheiden sich lediglich darin, wohin die Ausgaben gehen. Außerdem sind die Intrinsic Objects von CScript ein klein wenig mächtiger als die von WScript.

WScript.exe

WScript ist der Standard; bei der Installation des WSH werden die WSH-Dateiextensionen mit WScript verknüpft.

Diese Verknüpfungen können in der Registry, in den Optionen des Windows Explorers oder mit der WSH-Kommandozeilenoption //H: geändert werden.

Bei WScript (implementiert in WScript.exe) erfolgt die Ausführung als Windows-Anwendung.

Alle Ausgaben werden in Form von Dialogboxen dargestellt. Wenn das Skript viele Ausgaben macht, kann dies sehr lästig sein, da jede Dialogbox einzeln bestätigt werden muss. Zudem ist jede Dialogbox modal: Das Skript hält an und wartet auf die Bestätigung. WScript eignet sich also für die unbeaufsichtigte Ausführung nur dann, wenn das Skript keine Ausgaben macht. Gut geeignet ist WScript jedoch dann, wenn der Benutzer über jeden einzelnen Schritt informiert werden und dabei die jeweils erfolgten Veränderungen überprüfen möchte (also beispielsweise beim Debugging von Skripten).

CScript.exe

Bei CScript (implementiert in CSCRIPT.EXE) erfolgt die Ausführung des Skripts im Kontext einer Kommandozeile (auch: Konsole oder DOS-Box).

Die Form der Ausgabe hängt von den verwendeten Ausgabebefehlen ab. Alle Ausgaben über die Methode Echo() aus dem WSH-Intrinsic Object WScript erfolgen in die DOS-Box. Alle Ausgaben über die spracheigenen Ausgabemethoden (z.B. MsgBox() in VBScript) werden weiterhin als modale Dialogboxen dargestellt.

Ein Vorteil von CScript ist, dass es mit der Methode WScript.StdIn.ReadLine() das Einlesen von Eingaben des Benutzers im DOS-Fenster unterstützt.

CScript hat außerdem den Vorteil, dass die Skriptausführung mit (STRG)+(C) jederzeit vom Benutzer abgebrochen werden kann. Bei WScript hilft – wenn modale Dialogboxen angezeigt werden – nur das Beenden der Anwendung mit dem Windows Task-Manager.

Aus o. a. Gründen ist für EchoLinkPlus.vbs die Verwendung von CScript.exe anstelle WScript.exe zu empfehlen. Zwar wird ein zusätzliches (»DOS«)Fenster geöffnet - das während der Programmlaufzeit nicht geschlossen werden darf, aber die Anwendungen lassen sich sauber beenden. Mit CScript.exe kommt es kaum noch vor, dass nach Schließen der Anwendung Reste der Programme im System zurückbleiben, welche dann nur durch System-Neustart oder mittels Task-Manager entfernt werden können.

Ausführliche Informationen hierüber finden Sie im Internet unter

www.it-visions.de/default2.aspx?start=http://www.it-visions.de/(zr0fh3nkburuco4505yrcfm2)/lserver/faq.aspx?g=scripting

Der Start des Scriptes mit CScript.exe lässt sich durch vorherige Eingabe des Befehls

cscript //H:cscript

auf Kommandoebene (DOS-Fenster oder [Start] - [Ausführen] erzwingen.

Vorteilhaft lässt sich diese Prozedur durch eine Batch-Datei bewerkstelligen, etwa mit folgendem Inhalt:

[StartEchoLink.bat]

cscript //H:cscript

C:\Programme\K1RFD\EchoLink\scripts\EchoLinkPlus.vbs


EchoLinkPlusConfig

von DK6XH

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Konfiguration allgemein

Hinweis:

Wenn Sie mit der Bearbeitung von Scripten nicht gut vertraut sind und / oder keine bzw. nur geringe Kenntnisse über die VBScript-Programmierung haben, halten Sie sich bitte unbedingt an die in dieser Dokumentation enthaltenen Beschreibungen und Anweisungen oder benutzen die menügeführte Konfiguration (von den Autoren empfohlen!).

Ändern Sie nur Eintragungen im Bereich M A N U E L L E K O N F I G U R A T I O N . Bitte keine Änderungen im nachfolgenden Teil, insbesondere in dem Teil am Ende des Scriptes (Konfiguration in Registry schreiben), dies führt unweigerlich zu Fehlern bei der Konfiguration.

Konfiguration allgemein
ChkLinkRes = -1 | Bei jedem Update der EchoLink-Stationsliste wird überprüft, ob die eigene Station in dieser Liste enthalten ist. Ist dies nicht der Fall, so wird ein Reset von EchoLink durchgeführt. Für den Dauerbetrieb wird »-1« (True) empfolen; es kann vorkommen, dass der EchoLink-Server (z. B. bei Neuzuweisung der IP-Adresse nach 24 Stunden Dauerbetrieb durch den Provider) die eigene Station erst mal nicht erkennt. Mit dieser Option wird die sofortige Wiederaufnahme der eigenen Station in die Stationsliste erzwungen.
ChkLinkRes = 0 | Die Option der Linkprüfung ist ausgeschaltet.

Beachte hierzu auch:

Wenn ChkLinkRes = -1 gewählt wird, so müssen in [Tools] - [Preferences] die Einstellungen für das automatische Update der EchoLink-Stationsliste vorgenommen werden.

Hier wird eingestellt ob und in welchem Zyklus der Inhalt der Stationsliste erneuert wird.

Wenn das Häkchen bei »Update station list automatically« nicht gesetzt ist (nicht empfohlen), so wird die Stationsliste nicht erneuert.

Mit »Update every« wird der Zykus festgelegt (im Beispiel 300 Sekunden).

Das Häkchen neben »Even while connected« (für Stationen mit ausreichender Übertragungsgeschwindigkeit empfohlen) legt fest, dass ein Update der Stationsliste auch dann erfolgt, wenn eine EchoLink-Station connected ist.

Konfiguration allgemein
PreCmdDTMF = -1 | Festlegung, dass DTMF-Steuersignalen ein Zeichen (z. B. »A«) voran gestellt wird, das aber von EchoLink nicht ausgewertet wird.
PreCmdDTMF = 0 | DTMF-Steuersignalen wird kein ein Zeichen vorangestellt.

Konfiguration allgemein

PreCmdChar = "A"

Nur wenn PreCmd = -1: Zeichen, welches EchoLink-DTMF-Eingaben vorangestellt werden muss, aber von EchoLink nicht ausgewertet wird. Das Zeichen muss in " " stehen!

Konfiguration allgemein
ErrorCheck = -1 | Schaltet die DTMF-Fehler-Prüfung ein.
ErrorCheck = 0 | Schaltet die DTMF-Fehler-Prüfung aus.

Konfiguration allgemein
PriorLocalTraff = -1 | Lokaler Funkverkehr hat Vorrang vor EchoLink; wenn ein lokales QSO läuft, meldet EchoLink »Busy« und vom Repeater kommende DTMF-Befehle werden ignoriert. Siehe hierzu auch Stringvariablen und Zeitvariablen allgemein.
PriorLocalTraff = 0 | Lokaler Funkverkehr ist gleichberechtigt miit EchoLink.

Auswirkung »PriorLocalTraff = -1« auf die Anzeige in der EchoLink-Stationsliste

Kein lokaler Betrieb,

keine EchoLink-Station connected

Siehe hierzu auch StringVariablen .

EchoLink-Station (DB0XW) connected

Siehe hierzu auch StringVariablen .

Lokaler Betrieb

Siehe hierzu auch StringVariablen .

Konfiguration allgemein
SuspLocalOnly = -1 | EchoLink wird zu den eingestellten Zeiten (z. B. für feste Rundspruchzeiten) in den Status »Busy« geschaltet und vom Repeater kommende DTMF-Befehle werden in dieser Zeit ignoriert. Siehe hierzu auch Zeitvariablen allgemein.
SuspLocalOnly = 0 | Die Funktion ist ausgeschaltet.

Konfiguration allgemein
SuspTemp = -1 | EchoLink wird zu den eingestellten Zeiten dissabled - »Nachtabschaltung«
SuspTemp = 0 | Die Funktion ist ausgeschaltet

Konfiguration allgemein
QuickConnect = -1 | Connect erfolgt über die DTMF-Auswertung des Scriptes - dadurch werden die EchoLink-Ansagen - bis auf das Rufzeichen - unterdrückt.
QuickConnect = 0 | Normaler Connectaufbau.

Beachte hierzu auch:

Wenn QuickConnect = -1, darf in Sysop Setup DTMF das Feld »Connect« nicht leer bleiben.

X (oder mehrere von DTMF nicht auswertbare Zeichen) bewirkt, dass die EchoLink-Ansagen bis auf das Rufzeichen unterdrückt werden.

Wir hier ein »A« eingetragen, so besteht für den Benutzer die Möglichkeit, entweder nur die Node-Nummer der zu connectenden Station einzugeben und eine kurze Ansage zu erhalten oder der Node-Nummer ein »A« voranzustellen, um eine ausführliche Ansage zu erhalten.

Beispiel:

Eingabe: 14422

Ansage (1): DB0UA-Repeater
Ansage (2): keine (nur Zeichen für Verbindungsaufbau)

Eingabe: 14423

Ansage (1): Not found (wenn es diese Nummer nicht gibt)
Ansage (2): keine (auch wenn es diese Nummer nicht gibt)

Eingabe: A14422

Ansage: Connecting to DB0UA-Repeater

Eingabe: A14423

Ansage: A-1-4-4-2-3- not found

(1), (2)
Abhängig von der Konfiguration in [Tools] - [Sysop Setup] - Reiterkarte [Options].

(1) Wenn in [Tools] - [Sysop Setup] - Reiterkarte [Options] bei »Include callsign« ein Häckchen gesetzt ist.

(2) Wenn in [Tools] - [Sysop Setup] - Reiterkarte [Options] bei »Include callsign« kein Häckchen gesetzt ist.

Beachte hierzu auch:

Wenn QuickConnect = -1, so kann durch das Programm EchoLink keine Überprüfung stattfinden, ob das zu connectende Call gemäß
Listeneintrag »Accept only these calls:«
freigegeben bzw.
Listeneintrag »Deny these calls:«
gesperrt ist.

Nachdem bei Repeater- oder Link-Betrieb wohl meist »Deny these calls:« gesetzt ist, wurde dies in EchoLinkPlus derart gelöst, dass in diese Liste nicht das jeweilige Rufzeichen der zu sperrenden Station einzutragen ist sondern die entsprechende Knotennummer (Node Number).

Im links dargestellten Beispiel sind dies beispielsweise

  • [9999] EchoLinkTestServer
    wird in Augsburg nicht benötigt, weil das Relais über einen eigenen »Papagei« zur Beurteilung der eigenen Modulation verfügt.

  • [14422] DB0UA (in diesem Falle die eigene Station)
    Es macht keinen Sinn, sich selber zu connecten.

  • [6504] ZL1VK-R
    Der Begrüßungstext von ZL1VK mit den Wildgänsen ist zwar ganz nett, wenn das aber zwanzig Mal hintereinander über die Relaisausgabe kommt, finden das manche User nicht mehr besonders lustig.

EchoLinkPlus überprüft vor einem Connect, ob die gewählte Knotennummer in dieser Liste (= Eintrag in der Registry) enthalten ist. Trifft dies zu, wird der Verbindungsaufbau abgebrochen. Es wird dann nur das entsprechende Rufzeichen der zu connectenden Station ausgegeben; darüber hinaus erfolgt keine weitere Meldung

Hinweis:
Apply security settings to: [ ] Inbound connection requensts - also von EchoLink eingehende Verbindungen sind hiervon nicht betroffen.

Konfiguration allgemein
SysAnnELPlus = -1 | Schaltet die Systemmeldungen & Ansagen: Die Ansagen und die Steuerung werden von EchoLinkPlus übernommen (Ansagen in Deutsch, EchoLink-Originalansagen werden disabled)
SysAnnELPlus = 0 | Ansagen erfolgen im Original vom EchoLink

Konfiguration allgemein
AutoUpdateELP = -1 | Der Refresh der Echolink-Stationsliste wird von EchoLink+ übernommen
AutoUpdateELP = 0 | Für den Refresh gelten die Einstellungen im Programm "EchoLink.exe"

Konfiguration allgemein
UpdateInQSOELP = -1 | nur relevant wenn AutoUpdateELP eingeschaltet ist: Der Refresh der Echolink-Stationsliste erfolgt auch während eines QSOs
UpdateInQSOELP = 0 | Es erfolgt kein Refresh während eines QSOs (nur relevant wenn langsame Internet-Verbindung)

Konfiguration allgemein

RefreshIntervalELP = 300

nur relevant wenn 'AutoUpdateELP: eingeschaltet ist

Zyklus [s], in dem ein Refresh durchgeführt wird - Bereich: 200s ... 1000s; default: 300


Kurzbeschreibung

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Menügeführte Konfiguration

Seit der Version 2.1 gibt es die Möglichkeit der menügesteuerten Konfiguration zu EchoLinkPlus.vbs. Bei dieser Art der Konfiguration werden einzelne Eingabefenster geöffnet, die mit <Ja> oder <Nein> bestätigt werden müssen oder in die ein Wert einzutragen oder zu ändern ist.

Vorbereitung EchoLink.exe

Es wird empfohlen, vor der Konfiguration von EchoLinkPlus im Programm EchoLink.exe ein neues Profil anzulegen.

Hierzu starten Sie das Programm EchoLink.exe über die Menüfunktion »File - Profiles.

Klicken Sie auf den Button [New] und legen sie ein neues Profil an.

In dem gezeigten Beispiel ist dies »EchoLink+«.

Setzen Sie bei »Always start with selected profile« ein Häkchen.

Klicken Sie auf [OK].

EchoLink.exe führt einen Reset durch.

Danach ist das neu erstellte Profil das Startprofil.

Aufruf von EchoLinkPlusConfig.vbs

Hierzu rufen Sie das im Verzeichnis »...\Programme\K1RFD\EchoLink\EchoLinkPlus« enthaltene Script EchoLinkPluConfigs.vbs auf.

Wenn Sie hierzu auf Ihrem Desktop einen Link erstellt haben, einfach auf das Icon klicken.

Nach dem Start von EchoLinkPlusConfig.vbs erscheint zunächst eines der beiden folgenden Eingabefenster:

Hinweis:

Sollte noch kein eigenes Profil für EchoLinkPlus angelegt worden sein, also hier wie im linken Bild "MAIN" stehen, so sollte hier abgebrochen werden und in EchoLink.exe zunächst ein eigenes Profil "EchoLinkPlus" erstellt und dieses als Standard definiert werden.

Das hat den Vorteil, dass man jederzeit auf die alte Einstellung zurückgreifen kann.

Ist ein neues Profil für EchoLinkPlus angelegt worden, so empfiehlt es sich nun die Konfiguration interaktiv durchzuführen und [Ja] anzuklicken oder mit der RETURN-Taste zu bestätigen.
Wird eine frühere Version von EchoLinkPlus gefunden, so findet hier eine Abfrage statt, ob die alten Werte übernommen werden sollen.

Wenn man nicht von Grund an neu installieren möchte, empfiehlt es sich hier die alten Werte zu übernehmen und [Ja] anzuklicken oder mit der RETURN-Taste zu bestätigen.

Wurde ein neues Profile für EchoLinkPlus erstellt und als Standard eingestellt, so wird dieses Profil auch hier bereits eingetragen sein.

Es ist aber hier möglich, jedes bestehende Profil anzugeben.

Mit [OK] geht es weiter.

Es folgt noch einmal ein Hinweis auf das Auslesen der alten Werte.

Hier kann man zur Not noch abbrechen.

Mit [OK] geht es weiter.

Hier ist man nun im eigentlichen Menü angelangt.

Die neun Menüpunkte lassen nun zu, dass man nur einzelne Bereiche konfiguriert [1] bis [8], oder alles [9], was bei einer Neuinstallation zu empfehlen ist.

Jeder Menüpunkt kann später dann einzeln aufgerufen werden und am Ende das Konfigurationsscript geschlossen werden.

Der weitere Ablauf ist nicht mehr bebildert.
Die Untermenüs sind selbsterklärend, so dass hier auf
eine detaillierte Beschreibung verzichtet wird.

Am Ende eine jeden Untermenüs erhält man nochmals einen Hinweis über die erfolgte Konfiguration.

Hier kann man zur Not noch abbrechen.

Mit [OK] geht es weiter.

Sind die Untermenüs alle konfiguriert oder ein ausgewähltes Untermenü abgeschlossen, so erhält man wieder das Auswahlmenü, jetzt jedoch noch um drei Menüpunkte erweitert.

[A] kehrte wieder zum Anfang zurück

[S] speichert die Konfiguration

[0] beendet das Programm

Es können hier also weitere Änderungen vorgenommen werden, oder das Programm mit oder ohne Änderung verlassen werden.

Ganz am Ende wird das Konfigurationsscript mit diesem Fenster (siehe links) abgeschlossen.

Voraussetzung für EchoLinkPlus Vers. 2.1.0

Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0. EchoLinkPlus kann sowohl neu eingerichtet werden, als auch ein Update von Version 2.0.0 erfolgen. Die Parameter werden dann automatisch mit in die neue Konfiguration übernommen.

Hinweis:

Vor dem Start von EchoLinkPlus.vbs muss das Konfigurierungsprogramm EchoLinkPlusConfig.vbs mindestens ein Mal aufgerufen worden sein.

Dies ist erforderlich, weil EchoLinkPlusConfig.vbs die darin festgelegten Parameter und Werte in die Windows-Registry schreibt.

Nach Start des ausführenden Programms EchoLinkPlus.vbs werden diese Parameter und Werte aus der Registry gelesen und stehen damit für die Programmausführung zur Verfügung.

Haftungsausschluss

Jegliche Haftung für enthaltene Fehler sowie Fehler in den Anwendungen EchoLinkPlus.vbs und EchoLinkPlusConfig.vbs ist ausgeschlossen.

Die Verwendung erfolgt ausschließlich auf eigenes Risiko und eigene Gefahr.

Wer diese Anwendungen benutzt, erkennt diesen Haftungsausschluss ab der ersten Nutzung an.

Zu dieser Dokumentation

Diese Dokumentation wurde erstellt von DK6XH & DC4FS.

Stand: 02 - 27.03.2004


Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Konfiguration der Ansagen

Konfiguration der Ansagen
Announcements = -1 | Ansagen über den lokalen Repeater aktiviert.
Announcements = 0 | Ansagen nicht aktiviert.

Konfiguration der Ansagen
AnnIfNotTraff = -1 | Ansagen (außer Zeitzeichen) deaktiviert, wenn x Sekunden (für x siehe Zeitvariablen der Ansagen) vorher eine Linkverbindung bestand (EchoLink-Station connected) bzw. eine Relaisstation empfangen wurde.
AnnIfNotTraff = 0 | Wird nicht berücksichtigt.

Konfiguration der Ansagen
AnnIfNotRxOn = -1 | Call- und Zeitansage deaktiviert, wenn kurz vor der Ansage ein Signal vom Repeater empfangen wurde.
AnnIfNotRxOn = 0 | Wird nicht berücksichtigt (Kollisionsrisiko!) - kann aber bei VOX-gesteuerten Verbindungen zum Repeater erforderlich sein, weil dessen Signale eine Übertragung blockieren. In diesem Fall geht alles »in einem Rutsch raus«.

Konfiguration der Ansagen
AnnCall = 1 | Die jeweils ausgewählte Wav-Datei mit dem Rufzeichen (Stationskennung) des Repeaters (Callxx.wav) wird zu jeder vollen Stunde über den lokalen Repeater ausgegeben.
AnnCall = 2 | Die jeweils ausgewählte Wav-Datei mit dem Rufzeichen (Stationskennung) des Repeaters (Callxx.wav) wird halbstündlich über den lokalen Repeater ausgegeben.
AnnCall = 0 | Es wird keine Stationskennung ausgegeben.

Konfiguration der Ansagen
AnnTimeSig = 1 | Zu jeder vollen Stunde wird ab der 56. Sekunde bis zum Übergang von der 59. auf die 60. Sekunde ein Zeitzeichen ausgegeben; Frequenz = 1000 Hz.
AnnTimeSig = 2 | Zu jeder vollen und halben Stunde wird ab der 56. Sekunde bis zum Übergang von der 59. auf die 60. Sekunde ein Zeitzeichen ausgegeben; 00 Min: Frequenz = 1000 Hz; 30 Min: Frequenz = 500 Hz
AnnTimeSig = 0 | Es wird kein Zeitzeichen ausgegeben.

Konfiguration der Ansagen
AnnTime = 1 | Die jeweils aktuelle Uhrzeit wird stündlich angesagt, wenn die Ausgabe nicht aufgrund der in den Zeitvariablen tAskPreTraffRX und tAskPreTraffRec zugewiesenen Werten gesperrt ist..
AnnTime = 2 | Die jeweils aktuelle Uhrzeit wird halbstündlich angesagt, wenn die Ausgabe nicht aufgrund der in den Zeitvariablen tAskPreTraffRX und tAskPreTraffRec zugewiesenen Werten gesperrt ist..
AnnTime = 3 | Die jeweils aktuelle Uhrzeit wird stündlich angesagt, wenn die Ausgabe nicht aufgrund der in den Zeitvariablen tAskPreTraffRX und tAskPreTraffRec zugewiesenen Werten gesperrt ist.
AnnTime = 0 | Es wird keine Uhrzeit ausgegeben.

Konfiguration der Ansagen
AnnTimeVoice = 1 | Ansagestimme männlich (male).
AnnTimeVoice = 2 | Ansagestimme weiblich (female).
AnnTimeVoice = 3 | Ansagestimme abhängig vom Ansagetext »Call« (nur sinnvoll, wenn AnnCall = 1 oder 2)
AnnTimeVoice = 4 | Wie 3, nur halbstündlich männlich (male).
AnnTimeVoice = 5 | Wie 3, nur halbstündlich weiblich (female).
AnnTimeVoice = 0 | Zufallsauswahl für Ansagestimme männlich oder weiblich.

Konfiguration der Ansagen
AnnActMsg = 1 | Ausgabe einer aktuellen Mitteilung (_ActMsgx.wav) zu jeder vollen Stunde.
AnnActMsg = 2 | Ausgabe einer aktuellen Mitteilung (_ActMsgx.wav) halbstündlich.
AnnActMsg = 0 | Es wird keine aktuelle Mitteilung ausgegeben.

Konfiguration der Ansagen

NumberActMsg = 1

Anzahl der aktuellen Meldungen, die (wenn mehr als 1) zufällig ausgewählt werden.

Hierzu muss AnnActMsg = 1 oder AnnActMsg = 2 sein, ansonsten nicht relevant.

Die Dateien »ActMsgx.wav« müssen im entsprechenden Verzeichnis sein mit der jeweiligen Nummer für »x« (also bei drei Dateien »ActMsg1.wav«, »ActMsg2.wav« sowie »ActMsg3.wav«.

Konfiguration der Ansagen
PreOpenRepeater = 1 | Vor Beginn der Ansagen wird der TX für die in Zeitvariablen der Ansagen in der Variablen tPreOpenRepDur eingestellte Zeitdauer eingeschaltet (falls Repeater trägergesteuert oder CTCSS). Siehe hierzu auch Zeitvariablen der Ansagen tPreOpenRepSI und tPreOpenRepTS.
PreOpenRepeater = 2 | Wie PreOpenRepeater = 1, jedoch wird zusätzlich ein 1750 Hz Rufton gesendet. Siehe hierzu auch Zeitvariablen der Ansagen tPreOpenRepSI und tPreOpenRepTS.
PreOpenRepeater = 0 | Funktion deaktiviert.

Konfiguration der Ansagen
AnnActTime = -1 | Ansage der aktuellen Zeit nach Empfang der DTMF-Sequenz **.
AnnActTime = 0 | Funktion deaktiviert.

Konfiguration der Ansagen
InfoEcho = 1 | Informationtexte DTMF *0 ... *9 permanent abrufbar.
InfoEcho = 2 | Informationtexte DTMF *0 ... *9 zu bestimmten Zeiten abrufbar.
InfoEcho = 0 | Funktion deaktiviert.

Konfiguration der Ansagen
InfoEchoBeep = -1 | Nach Ausgabe eines Infotextes wird ein Rogerpeep gesendet.
InfoEchoBeep = 0 | Funktion deaktiviert.

Konfiguration der Ansagen
AnnSysopModCW = -1 | SysopMode wird bei Beginn und Beendigung durch Ausgabe eines CW-Zeichens (Beginn: »S«; Ende: »T«) signalisiert.
AnnSysopModCW = 0 | SysopMode wird bei Beginn und Beendigung durch das Abspielen einer entsprechenden wav-Datei signalisiert.

Konfiguration der Ansagen

NumberOfCallFile = 12

Anzahl Files "CallXX.wav" für Ansage StationCallbei stündlicher / halbstündlicher Zeitansage


Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Konfiguration Directories

Hinweis:

Wenn Sie mit der Bearbeitung von Scripten nicht gut vertraut sind und / oder keine bzw. nur geringe Kenntnisse über die VBScript-Programmierung haben, halten Sie sich bitte unbedingt an die in dieser Dokumentation enthaltenen Beschreibungen und Anweisungen oder benutzen die menügeführte Konfiguration (von den Autoren empfohlen!).

Ändern Sie nur Eintragungen im Bereich M A N U E L L E K O N F I G U R A T I O N . Bitte keine Änderungen im nachfolgenden Teil, insbesondere in dem Teil am Ende des Scriptes (Konfiguration in Registry schreiben), dies führt unweigerlich zu Fehlern bei der Konfiguration.

NEU:

Der Pfad von EchoLink.exe wird aus der Registry ausgelesen und in der Variablen "PathEchoLink" abgespeichert.

Nach der Installation von EchoLinkPlus 2.1 wird automatisch ein Unterverzeichnis "EchoLinkPlus" angelegt.

In diesem Unterverzeichnis befindet sich der Ordner "Wav", in dem alle von EchoLinkPlus benötigen Wav-Dateien installiert wurden.

Selbst erstellte Wav-Dateien aus der Version 2.0.0 können in dieses Verzeichnis kopiert werden.

Konfiguration Directories

WavCallDir = "PathEchoLink & "\EchoLinkPlus\wav\Call"

Directory in dem sich die wav-Dateien für die StationsInfo und Ansage der deutschen Rufzeichen befinden, mit erstem Teil des Dateinamens (Call...) der jeweils abzuspielenden *.wav-Datei.

Konfiguration Directories

WavInfoEchoDir = PathEchoLink & "\EchoLinkPlus\wav\InfoEcho"

Directory in dem sich die wav-Dateien für die mit DTMF-Sequenzen abrufbaren Informationstexte befinden, mit erstem Teil des Dateinamens (InfoEcho...) der jeweils abzuspielenden *.wav-Datei.

Konfiguration Directories

WavTimeDir = PathEchoLink & "\EchoLinkPlus\wav\Time"

Directory in dem sich die wav-Dateien für die Zeitansagen befinden, mit erstem Teil des Dateinamens (Time...) der jeweils abzuspielenden *.wav-Datei.

Konfiguration Directories

WavActTimeDir = PathEchoLink & "\EchoLinkPlus\wav\ActTime"

Directory in dem sich die wav-Dateien für die Zeitansagen befinden, mit erstem Teil des Dateinamens (ActTime...) der jeweils abzuspielenden *.wav-Datei.

Konfiguration Directories

WavActMsgDir = PathEchoLink & "\EchoLinkPlus\wav\_ActMsg"

Directory in dem sich die wav-Dateien fuer die aktuelle Mitteilung befinden, mit erstem Teil des Dateinamens (ActMsg...) der jeweils abzuspielenden *.wav-Datei.

Verzeichnis wav-Dateien

In nachfolgender Aufstellung sind alle wav-Dateien enthalten, die benötigt werden, wenn alle Ansagen konfiguriert sind.

WavCallDir

Call1.wav

Call2.wav

...

Call12.wav

CallF0.wav

CallF1.wav

...

CallF9.wav

CallFA.wav

CallFB.wav

...

CallFZ.wav

CallFAe.wav

CallFBe.wav

...

CallFZe.wav

CallF0.wav

CallF1.wav

...

CallF9.wav

CallMA.wav

CallMB.wav

...

CallMZ.wav

CallMAe.wav

CallMBe.wav

...

CallMZe.wav

CallCon.wav

CallRep.wav

CallLin.wav

Dateien Ausgabe Rufzeichen / Repeater-Info

WavInfoEchoDir

InfoEcho0.wav

InfoEcho1.wav

...

InfoEcho9.wav

InfoEchoAC.wav

InfoEchoActConn.wav

InfoEchoBeep.wav

InfoEchoCallOff.wav

InfoEchoCallOn.wav

InfoEchoDeny.wav

InfoEchoDispBusy.wav

InfoEchoError.wav

InfoEchoFalse.wav

InfoEchoJustAutoDisc.wav

InfoEchoJustDisc.wav

InfoEchoLastConn.wav

InfoEchoLDeny.wav

InfoEchoLError.wav

InfoEchoLinkBusy.wav

InfoEchoLinkBusyOn.wav

InfoEchoLinkEnable.wav

InfoEchoLinkOff.wav

InfoEchoLinkOn.wav

InfoEchoListenOff.wav

InfoEchoListenOn.wav

InfoEchoLNotFound.wav

InfoEchoLStationBusy.wav

InfoEchoMsgOn.wav

InfoEchoNode.wav

InfoEchoNotConn.wav

InfoEchoNotFound.wav

InfoEchoOver.wav

InfoEchoPreAutoDisc.wav

InfoEchoPriorLocalOff.wav

InfoEchoPriorLocalOn.wav

InfoEchoStationBusy.wav

InfoEchoStationInfo1.wav

InfoEchoStationInfo2.wav

InfoEchoStillConnected.wav

InfoEchoSuspLocalOff.wav

InfoEchoSuspLocalOn.wav

InfoEchoSuspTempOff.wav

InfoEchoSuspTempOn.wav

InfoEchoSwitchOffEchoLink.wav

InfoEchoSysopOff.wav

InfoEchoSysopOn.wav

InfoEchoTimerOff.wav

InfoEchoTimerOn.wav

Informationstexte, diverse Ansagen

WavTimeDir

TimeF0.wav

TimeF1.wav

...

TimeF23.wav

TimeF30.wav

TimeM0.wav

TimeM1.wav

...

TimeM23.wav

TimeM30.wav

Dateien für die Ansage der Zeit zur vollen und halben Stunde

WavActTimeDir

ActTime00uhr.wav

ActTime01uhr.wav

ActTime02uhr.wav

ActTime03uhr.wav

...

ActTime22uhr.wav

ActTime23uhr.wav

ActTime01min.wav

ActTime02min.wav

...

ActTime59min.wav

Dateien für die Ansage der aktuellen Zeit

WavActMsgDir

ActMsg1.wav

ActMsg2.wav

...

ActMsgx.wav

Aktuelle Mitteilungen


Konfiguration Massnahmen gegen Missbrauch

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Konfiguration Maßnahmen gegen Missbrauch

Konfiguration Massnahmen gegen Missbrauch

ChkDiscLink = -1

Überprüfung Plausibilität eines Disconnect durch DTMF # oder ##.

Bei Empfang der DTMF-Zeichen # oder ## wird gewartet, ob weiter gesprochen wird.

Die Überprüfung findet jeweils 3, 4 und 5 Sekunden nach Auswertung dieser Zeichen statt.

Ist zu allen drei Zeiten eine Station (von EchoLink oder vom Repeater) aktiv, wird die Anforderung zum Disconnect verworfen.

Auch wenn das Verhältnis Gesamtzeit (5s) / Signalzeit gößer als 75% beträgt, wird ebenfalls die Verbindung gehalten, andernfalls wird der Disconnect ausgeführt.

ChkDiscLink = 0

Es findet keine Überprüfung statt.

Beachte hierzu auch:

Wenn ChkDiscLink = -1, so müssen die Einstellungen in [Tools] - [Sysop Setup] - Reiterkarte [DTMF] entsprechend angepasst werden.

Die Felder »Sequence« neben »Function« [Disconnect] und [DisconnectAll] dürfen nicht die Zeichen # bzw. ## enthalten.

Alternativ kann eine andere Sequenz eingegeben werden, wie in nebenstehendem Beispiel gezeigt (0951 für DisconnectAll) - womöglich als Alternative für den Sysop.
Ein angeforderter Disconnect mit dieser Sequenz wird nicht auf Plausibilität überprüft.

Konfiguration Massnahmen gegen Missbrauch
ConnectGuard = -1 | Auswertung Fehlconnect mit automatischem Disconnect. Nach etwa einer Minute wird eine EchoLink-Station, die keine oder zu kurze Umschaltpausen lässt, automatisch abgeworfen.
ConnectGuard = 0 | Die Funktion ist deaktiviert.

Konfiguration Massnahmen gegen Missbrauch

GuardAutoDiscAgain = -1

Nach einem erfolgten automatischem Disconnect wird die eine EchoLink-Station, die keine oder zu kurze Umschaltpausen lässt, bereits nach 30 Sekunden automatisch abgeworfen.

Im Falle eines weiteren Connectversuches nach automatischem Disconnect der gleichen EchoLink-Station wird EchoLink vorübergehend ausgeschaltet.

GuardAutoDiscAgain = 0

Die Funktion ist deaktiviert.

Konfiguration Massnahmen gegen Missbrauch
GuardCallCount = -1 | Bei häufig wiederholten Abfragen von Infotexten (»Spaßvogel« will Zuhörer nerven) erfolgt eine vorübergehende Deaktivierung der Wiedergabefunktion der Infotexte.
GuardCallCount = 0 | Die Funktion ist deaktiviert.


von DK6XH

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

DTMF-StringVariablen

DTMF-StringVariablen

Password = "*0122333"

Passwort für den Sysop-Modus.
Der String muss sich von allen anderen möglichen DTMF-Eingaben unterscheiden (Steuerfunktionen, Kurzwahlnummern, Node-Nummern) und in " " stehen!

Sinnvollerweise ist er länger als 6 Zeichen.


von DK6XH

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

StringVariablen

Nachfolgend beschriebene Einstellungen sind nur gültig bzw. sinnvoll, wenn PriorLocalTraff = -1 (eingeschaltet) ist.

StringVariablen

sLinkFree = "Augsburg (JN58LI)"

Text in der EchoLink-Stationsliste wenn die eigene EchoLink-Station ONLINE ist (weder mit einer anderen EchoLink-Station verbunden, noch in einem Local-QSO).
Der String (in diesem Beispiel »Augsburg (JN58LI)«) muss in " " stehen!

Siehe auch Konfiguration allgemein Variable PriorLocalTraff.

StringVariablen

sLocalBusy = "BUSY: Local QSO"

Text in der EchoLink- Stationsliste wenn über den Repeater ein Local-QSO läuft.
Der String (in diesem Beispiel »BUSY: Local QSO«) muss in " " stehen!

Siehe auch Konfiguration allgemein Variable PriorLocalTraff.

StringVariablen

sEchoLinkBusy = "BUSY: QSO with "

Text in der EchoLink- Stationsliste wenn eine EchoLink-Verbindung besteht.
Der String (in diesem Beispiel »BUSY: QSO with «) muss in " " stehen!

Siehe auch Konfiguration allgemein Variable PriorLocalTraff.

StringVariablen
bCallIfELBusy = -1 | Das Rufzeichen der connecteten EchoLink-Station wird in der EchoLink-Stationsliste angezeigt. Zum Beispiel: »BUSY: QSO with DB0XW« Siehe auch Konfiguration allgemein Variable PriorLocalTraff.
bCallIfELBusy = 0 | Das Rufzeichen der connecteten EchoLink-Station wird in der EchoLink-Stationsliste nicht angezeigt.

Beachte hierzu auch:

»bCallIfELBusy = -1« ist nur empfehlenswert, wenn in [Tools] - [Preferences] - [Connections] im Feld [Conferencing] die Option »Allow conferences« nicht gewählt ist (Häkchen entfernen).

Anmerkung:

Die bisherigen Erfahrungen in Augsburg (DB0UA-2m) haben gezeigt, dass es sinnvoll ist, nur jeweils einen EchoLink-Connect zuzulassen. So ist vermeidbar, dass beispielsweise eine EchoLink-Station die Repeaterstation connected, auf ihren Ruf keine Antwort bekommt, eine weitere EchoLink-Station hinzu kommt und dann beide ein QSO von PC zu PC beginnen, das über den mittlerweile völlig unbeteiligten Repeater übertragen wird.

Converences sind dabei trotzdem möglich, wenn diese Rolle die externe EchoLink-Station übernimmt.


Zeitvariablen_allgemein

von DK6XH

Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Zeitvariablen allgemein

Zeitvariablen allgemein

tRepHoldTime = 10

Haltezeit in Sekunden [s] des Repeater-Senders nach Schließen der Empfänger-Rauschsperre.

Diese Variable wir ausgewertet bei Signalisierung eines Disconnects.

Erfolgt der Disconnect nach Ablauf dieser Zeit, so wird die Meldung nicht ausgesendet; dies vermeidet das Hochtasten des Senders (z. B. nach Inactivity Timeout) nur für diese Meldung (die dann vermutlich sowieso niemanden mehr interessiert).

Zeitvariablen allgemein

tRepPostTime = 9

Nachhaltezeit für den Repeater nach TXoff, während der kein Rufton erforderlich ist, um den Repeater wieder aufzutasten.

Zeitvariablen allgemein

tPreOpenRepTS = 9

Zeit zwischen dem Öffnen des Repeaters und dem Beginn der Ansage (StationsCall) bzw. Zeitzeichen. Verzögerung zur Vermeidung des Übersprechens der Rufzeichenausgabe, etc.)

Zeitvariablen allgemein

tReconnectTime = 300

Zeit in Sekunden [s] für die Möglichkeit eines Reconnects der letzten EchoLink-Station mittels DTMF-Folge »09«.

Damit soll verhindert werden, dass ein unbeabsichtigter Reconnect nach längerer Zeit (u. U. noch nach Stunden) zu einer EchoLink-Station erfolgt.

Zeitvariablen allgemein
tAnnBusyTime = 7200 | Sperrzeit in Sekunden [s] für die ausführliche Statusmeldung »EchoLink ausgeschaltet« nach einmal erfolgter Ansage; in dieser Zeit erfolgt nur eine kurze Ansage oder ein Zeichen (gem. der gewählten wav-Datei).
tAnnBusyTime = 0 | Es erfolgt keine Statusmeldung.

Zeitvariablen allgemein

tLocalRxOnT = 16

Ungefähre Zeit, die zur Schaltung in "NUR LOKALER BETRIEB - EchoLink Busy" erforderlich ist.

Zeitvariablen allgemein

tLocalRxOn = 40

Wert für die Zeitdauer, bis bei lokalem Repeater-Betrieb (keine EchoLink-Station connected) EchoLink für die Zeitdauer des lokalen Betriebs ausgeschaltet wird.
Hierzu muss in Konfiguration allgemein die Variable PriorLocalTraff = -1 gesetzt sein und für tLocalRxOnS ein Wert angegeben werden. Ebenso muss für die Haltedauer Lokalbetrieb der Variablen tBusyHoldTime ein Wert zugewiesen werden; ansonsten sind die Einstellungen hier nicht relevant.

Die genaue Zeit hängt vom Wert der Zeitvariablen tLocalRxOnS ab sowie vom jeweiligen Funkverkehr. Ist der Wert von tLocalRxOnS = 4, dann bei ununterbrochenem Träger der Wert tLocalRxOn = 40 nach ca. 11 Sekunden erreicht. Bei Unterbrechungen erhöht sich die Zeitdauer, weil der Zählerwert für tLocalRxOn in den Sendepausen jede Sekunde um 1 zurück gezählt wird.

Die Einstellung in diesem Beispiel (40) hat sich in Augsburg bewährt.

Zeitvariablen allgemein

tLocalRxOnS = 4

Zeit in Sekunden [s] für die Zeit, in der der Repeater-Squelch (RxSignal = On) geöffnet sein muss, dass die Zählung gewertet wird. Werte < 4 werden verworfen.

Hierzu muss in Konfiguration allgemein die Variable PriorLocalTraff = -1 gesetzt sein und für tLocalRxOn ein Wert angegeben werden. Ebenso muss für die Haltezeit Lokalbetrieb der Variablen tBusyHoldTime ein Wert zugewiesen werden; ansonsten sind die Einstellungen hier nicht relevant.

Falls erreicht, so wird dieser Wert (im Beispiel »4«) jede Sekunde zu »LocalRxOn« addiert, bis der eingestellte Wert von tLocalRxOn erreicht ist.

Zeitvariablen allgemein

tBusyHoldTime = 90

Zeit in Sekunden [s] für die Haltezeit Lokalbetrieb in der EchoLink ausgeschaltet bleibt, nachdem die Bedingungen für eine Umschaltung in den Lokalbetrieb erfüllt waren (tLocalRxOn und tLocalRxOnS)

Hierzu muss in Konfiguration allgemein die Variable PriorLocalTraff = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

Falls erreicht, so wird dieser Wert (im Beispiel »4«) jede Sekunde zu »LocalRxOn« addiert, bis der eingestellte Wert von tLocalRxOn erreicht ist.

Zeitvariablen allgemein

tSuspTempOff = 0

Uhrzeit (Stunde), zu der EchoLink temporär abgeschaltet wird (0 ... 23 Uhr).
Im gezeigten Beispiel erfolgt die Abschaltung um 0 Uhr.

Hierzu muss in Konfiguration allgemein die Variable SuspTemp = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

tSuspTempOn = 6

Uhrzeit (Stunde), zu der EchoLink wieder eingeschaltet wird (0 ... 23 Uhr).
Im gezeigten Beispiel erfolgt die Wiedereinschaltung um 6 Uhr.

Hierzu muss in Konfiguration allgemein die Variable SuspTemp = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

Zeitvariablen allgemein
tInfoEchoOff = 7 | Uhrzeit (Stunde), zu der Informationsabfragen (*0...*9) abgeschaltet werden (0 ... 23 Uhr). Im gezeigten Beispiel erfolgt die Abschaltung um 7 Uhr.
tInfoEchoOn = 22 | Uhrzeit (Stunde), zu der Informationsabfragen (*0...*9) eingeschaltet werden (0 ... 23 Uhr). Im gezeigten Beispiel erfolgt die Wiedereinschaltung um 22 Uhr.

Zeitvariablen allgemein

tLocalOnlyDay = 6

Wochentag der Ab- / Wiedereinschaltung.
1 = So, 2 = Mo, 3 = Di, 4 = Mi, 5 = Do, 6 = Fr, 7 = Sa
Im gezeigten Beispiel (tLocalOnlyDay = 6) erfolgt die Ab- / Wiedereinschaltung jeweils am Freitag.

Hierzu muss in Konfiguration allgemein die Variable SuspLocalOnly = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

tLocalOnlyHourOff = 18

Uhrzeit (Stunde) der Abschaltung (0 ... 23 Uhr)

Hierzu muss in Konfiguration allgemein die Variable SuspLocalOnly = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

tLocalOnlyMinOff = 53

Uhrzeit (Minute) der Abschaltung (0 ... 60 Min)

Hierzu muss in Konfiguration allgemein die Variable SuspLocalOnly = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

tLocalOnlyHourOn = 19

Uhrzeit (Stunde) der Wiedereinschaltung (0 ... 23 Uhr)

Hinweis:
Die Wiedereinschaltung muss am gleichen Tag erfolgen (Abschaltung 23.30 Uhr, Wiedereinschaltung eine Stunde später, also 0.30 Uhr, ist nicht möglich).

Hierzu muss in Konfiguration allgemein die Variable SuspLocalOnly = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.

tLocalOnlyMinOn = 28

Uhrzeit (Minute) der Wiedereinschaltung (0 ... 60 Min)

Hierzu muss in Konfiguration allgemein die Variable SuspLocalOnly = -1 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.


Version: | 2.1.0
Version EchoLink und EchoLinkPlus: | Vorausgesetzt wird das Programm EchoLink.exe von K1RFD, Version 1.8.874 und das Script EchoLinkPlus.vbs in der Version 2.1.0
Betriebssystem: | Windows 2000, 2000-Server, XP (Windows 95/98/ME wurden nicht getestet, sind aber womöglich auch geeignet. Benötigt wird außerdem Windows Script Host (WSH) Version 5.6 (kann bei Bedarf von der Internetseite von Microsoft herunter geladen werden).

Zeitvariablen der Ansagen

Zeitvariablen der Ansagen

tAskPreTraffRx = 60

Zeit in Sekunden [s] vor Ausgabe Zeitansage, in der keine Aussendung vom Relais empfangen wurde, ansonsten wird die Ausgabe von Stationsinfo und Zeitansage unterdrückt.

Siehe hierzu auch Konfiguration der Ansagen AnnIfNotTraff.

Zeitvariablen der Ansagen

tAskPreTraffRec = 60

Zeit in Sekunden [s] vor Ausgabe Zeitansage, in der keine Aussendung einer EchoLink-Station empfangen wurde, ansonsten wird die Ausgabe von Stationsinfo und Zeitansage unterdrückt.

Siehe hierzu auch Konfiguration der Ansagen AnnIfNotTraff.

Zeitvariablen der Ansagen

tAudioDelay = 0

Zeit in Millisekunden [ms] für einen vorzeitigen Start des Zeitzeichens.

Nur relevant, wenn der Repeater über AudioDelay verfügt, d. h., die empfangenen Signale werden zeitverzögert wiedergegeben (übliche Werte sind 64, 128, 256 ms).

Zeitvariablen der Ansagen

tPreOpenRepDur = 1000

Zeitdauer in Millisekunden [ms] der Aussendung (mit oder ohne Rufton) zum vorzeitigen Öffnen des Repeaters.

Hierzu muss in Konfiguration der Ansagen die Variable PreOpenRepeater = 1 oder PreOpenRepeater = 2 gesetzt sein; ansonsten sind die Einstellungen hier nicht relevant.